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Your Hosts

● Nick Boldt
● JBoss, a division of Red Hat
● Release Engineering (Modeling, Tools, Dash)

● Andrew Niefer
● IBM Rational
● PDE Build Maintainer

● Andrew Overholt
● Red Hat
● Linux Tools
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Tutorial Exercises & Slides
1. Get a USB drive from presenters & copy its contents to your 

drive. Also available here: 
http://www.eclipsecon.org/2009/sessions?id=302 

2. Unpack org.eclipse.dash.common.releng.tutorial_*.zip 
somewhere on your drive, eg.,  c:/tmp. This zip includes 
both exercises and slides.

3. Open Eclipse 3.5M6, and select 
File > Import > General > Existing Projects 

into Workspace

4. Browse to the workspace folder under where you unpacked the 
zip, eg.,

c:/tmp/org.eclipse.dash.common.releng.tutorial
/workspace/

http://www.eclipsecon.org/2009/sessions?id=302
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Tutorial Exercises  
(cont'd)

5. Import the following 6 projects from 
the workspace folder:

org.eclipse.dash.common.releng
org.eclipse.gef.releng
org.eclipse.gef.tree
org.eclipse.releng.basebuilder
XWT.BuildDirectory
XWT.Builder

Remember to check 
Copy projects into workspace.

Note that org.eclipse.releng.basebuilder 
will not compile due to one or more missing 
requirements. This is not a problem.
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● On the USB drive, there may also be a downloads folder. 

● You can choose to download those files manually or use 
the provided zips/jars AS-IS in order to save time 
re-downloading them. See README.txt for more information.

● You will need a copy of ant-contrib 1.0b2, and Eclipse 
(the rest is optional). 

● Copy ant-contrib.jar into your workspace here:
org.eclipse.dash.common.releng/lib/ant-contrib.jar

● If not using local files, you can get ant-contrib 1.0b2 here:
http://downloads.sourceforge.net/ant-contrib/ant-contrib-1.0b2-bin.zip

Third Party Code

http://downloads.sourceforge.net/ant-contrib/ant-contrib-1.0b2-bin.zip
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Builds ...
● Builds are a TMTOWTDI* problem

● Standardized = better

● Customization always required...
...but that leads away from standardization

* There's more than one way to do it
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Like layers of an onion

● Sources in VCS repository

● Packaging details, dependencies, maps
● PDE Build + setup scripts

● X server for running tests
● Web front end for monitoring & auditing
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OSGi Bundles
● META-INF/MANIFEST.MF

Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Plugin.name
Bundle-SymbolicName: org.eclipse.gef; singleton:=true
Bundle-Version: 3.4.0.qualifier
Bundle-Activator: org.eclipse.gef.internal.InternalGEFPlugin
Bundle-Vendor: %Plugin.providerName
Bundle-Localization: plugin
Import-Package: com.ibm.icu.text
Export-Package: org.eclipse.gef,
 org.eclipse.gef.commands,
 [...]
 org.eclipse.gef.util
Require-Bundle: org.eclipse.draw2d;visibility:=reexport;bundle-ver-
sion="[3.2.0,4.0.0)",
 org.eclipse.core.runtime;bundle-version="[3.2.0,4.0.0)",
 org.eclipse.ui.views;resolution:=optional;bundle-
version="[3.2.0,4.0.0)",
 org.eclipse.ui.workbench;bundle-version="[3.2.0,4.0.0)",
 org.eclipse.jface;bundle-version="[3.2.0,4.0.0)"
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: J2SE-1.4
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Bundle dependencies
● META-INF/MANIFEST.MF

Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %Plugin.name
Bundle-SymbolicName: org.eclipse.gef; singleton:=true
Bundle-Version: 3.4.0.qualifier
Bundle-Activator: org.eclipse.gef.internal.InternalGEFPlugin
Bundle-Vendor: %Plugin.providerName
Bundle-Localization: plugin
Import-Package: com.ibm.icu.text
Export-Package: org.eclipse.gef,
 org.eclipse.gef.commands,
 [...]
 org.eclipse.gef.util
Require-Bundle: org.eclipse.draw2d;visibility:=reexport;bundle-ver-
sion="[3.2.0,4.0.0)",
 org.eclipse.core.runtime;bundle-version="[3.2.0,4.0.0)",
 org.eclipse.ui.views;resolution:=optional;bundle-
version="[3.2.0,4.0.0)",
 org.eclipse.ui.workbench;bundle-version="[3.2.0,4.0.0)",
 org.eclipse.jface;bundle-version="[3.2.0,4.0.0)"
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: J2SE-1.4
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Bundle build description

● build.properties
bin.includes = about.*,\
               eclipse32.png,\
               plugin.xml,\
               plugin.properties,\
               icons/*.gif,\
               .,\
               META-INF/

bin.excludes = overview.html, **/doc-files/**

source.. = src/
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What is PDE Build?
● Ant script generator and build infrastructure

● Manages the compile time classpath based 
on OSGi dependencies

● The recommended way to build:
● Plug-ins / Bundles
● Features
● RCP apps

● Eclipse itself is built using PDE Build
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 The build uses scripts provided by PDE Build, as well as script 
generated at build time.

● Fetch source code
● Compile .class files
● Assemble the results into archives.

Overview of the builder
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What's new with PDE Build?

● 3.4
● Required configuration files are reduced to 

one file: build.properties
● Added customizability in the assembly and 

packaging phases of the build
● Enhanced feature generation capabilities
● Generation of individual source bundles

● 3.5
● p2 integration
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Exercise:  Build a feature

• Show how to build features
• Demystify PDE Build
• Introduce key concepts

Goals
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Relevant Part of PDE Build
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Exercise:  Build a feature
● Build the e4 XWT feature

● XWT is a collection of declarative bindings for SWT, used 
to generate SWT widgets from an XML file

● For setup, see slides 4-6. You will need:
● Eclipse 3.5M6
● JDK 5.0+
● 2 XWT projects – XWT.Builder and XWT.BuildDirectory
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Step 1:  The Build Directory
● The source to be compiled is in the build directory, structured 

under features and plugins folder like in a normal Eclipse in-
stall.

● This is where the build will run.  Generated scripts and build re-
sults will end up here.

Notes for releng:

• The location is defined by the ${buildDirectory} ant property 

• Make sure build directory and subdirectories are writeable

• This is where build will copy any source it fetches from CVS or 
other repositories.
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Step 2:  The Builder
The builder directory, aka the build configuration directory, 
contains the configuration files for the build.

● At a minimum, a build.properties file is required.
● Additional files can be placed here to customize the build.
● Templates of these files are provided in the templates folder of pde 

build
● The example includes an extra buildXWT.xml for the convenience of 

running the build in the workspace.

Notes for releng:

• The location is defined by the ${builder} ant property 

• Customization scripts (allElements.xml, customTargets.xml, 
customAssembly,xml) placed here will be used instead of the 
defaults – copy from pde build source and adjust as needed
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Step 3:  Setting Some Properties
● The build.properties in the builder folder contains all the switches to configure 

the overall aspect of the build.  The 4 properties that must be set for a build to 
run are:

topLevelElementId The feature id to be built
baseLocation Folder containing the plugins to build against
buildDirectory Folder containing the source to build (XWT.BuildDirectory)
builder Folder containing the build configuration (XWT.Builder)

● The builder property is specified on the command line for the build

In the example, we are only setting 
topLevelElementId = org.eclipse.e4.xwt.feature

For convenience we are setting the other properties using the buildXWT.xml ant 
script

The xwt plugins use 1.5 asserts so we also set “javacSource” and “javacTarget” properties here.
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Step 4:  The buildXWT.xml Script

<project default="main">
   <target name="main">
      <property name="builder" value="${basedir}" />
      <property name="buildDirectory" value="${basedir}/../XWT.BuildDirectory" />
      <property name="baseLocation" value="${eclipse.home}"/>

      <ant antfile="${eclipse.pdebuild.scripts}/build.xml" />
   </target>
</project>

The script is very simple, it sets the properties from Step 3 that 
we did not put in the build.properties file.

● builder : ${basedir} is the directory containing the script
● buildDirectory : Set to our XWT.BuildDirectory project, relative to the builder
● baseLocation : ${eclipse.home} is the eclipse we are running in
● ${eclipse.pdebuild.scripts}/build.xml is the main PDE Build 
script

Note: ${eclipse.home} and ${eclipse.pdebuild.scripts} are automatically set by Eclipse, see the Ant Runtime 
Preferences.  It is these two properties that make this kind of script a convenient way of running builds.
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Step 5:  Run The Build

Select the buildXWT.xml script and    
      “Run As → Ant Build...”

On the JRE tab, make sure that 
“Run in the same JRE as the workspace” 
is selected.

Once the build is complete, refresh the 
XWT.BuildDirectory project to see the re-
sults. 

Look in the new I.TestBuild folder.
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Step 5a:  Run The Build
(Command line version)

java –jar plugins\org.eclipse.equinox.launcher_<ver>.jar
-application org.eclipse.ant.core.antRunner 
-buildfile plugins\org.eclipse.pde.build_<ver>\scripts\build.xml 
-Dbuilder=<XWT.Builder> -DbuildDirectory=<XWT.BuildDirectory>
-DbaseLocation=C:\target\eclipse

On the command line, you can start eclipse by running “java -jar” 
on the equinox launcher.

● -application : the org.eclipse.ant.core.antRunner application.
● -buildfile : the main build.xml script provided by PDE Build
● -Dbuilder : the location of your builder directory

The “baseLocation” and “buildDirectory” properties are normally specified in the 
builder's build.properties file.  Though they can also be specified on the com-
mand line:
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Success
● We have an archive!

● See the resulting build
XWT.BuildDirectory/I.TestBuild/

org.eclipse.e4.xwt.feature-TestBuild.zip

● See the automatically generated scripts
assemble.org.eclipse.e4.xwt.feature.all.xml
assemble.org.eclipse.e4.xwt.feature.xml
package.org.eclipse.e4.xwt.feature.all.xml
package.org.eclipse.e4.xwt.feature.xml

● See the build log in
XWT.Builder/buildlog.latest.txt



Source code in this presentation is made available under the EPL, v1.0
The remainder of the presentation is licensed under Creative Commons Att. Nc Nd 2.5 li-
cense

Copyright © 2009 IBM Corp. & Red Hat, Inc.   All rights reserved.

Exercise: Generate a p2 Repository

3.4 version:  Add the following properties to the 
XWT.Builder build.properties file and run the build 
again to get p2 metadata.

generate.p2.metadata=true
p2.metadata.repo=file:${buildDirectory}/repo
p2.artifact.repo=file:${buildDirectory}/repo
p2.publish.artifacts=true

3.5M6 version:  Add the following property

p2.gathering=true

And notice the resulting archive is now a p2 repository.

org.eclipse.e4.xwt.feature-TestBuild-
group.group.group.zip
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Test Installation of Built Feature
● For normal zip, unpack into ~/eclipse/dropins/ 

and restart Eclipse using File > Restart.
● cd ~/workspace/XWT.BuildDirectory/I.TestBuild
● unzip org.eclipse.e4.xwt.feature-TestBuild.zip \

-d ~/eclipse/dropins/

● Check Help > About > Installation Details 
> Installed Software. Note the version number, 
eg., 0.9.0.v200903220728.
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Test Installation of Built Repo
● Next, install from the archived p2 repo.

● Help > Install New Software... > Add 

● Browse for org.eclipse.e4.xwt.feature-TestBuild-
group.group.group.zip

● Install the XWT feature (you may need to uncheck the Group 
items by category checkbox).

● Check Help > About > Installation Details > 
Installed Software. Note the version number will have 
increased, eg., 0.9.0.v200903220742.



Source code in this presentation is made available under the EPL, v1.0
The remainder of the presentation is licensed under Creative Commons Att. Nc Nd 2.5 li-
cense

Copyright © 2009 IBM Corp. & Red Hat, Inc.   All rights reserved.



Source code in this presentation is made available under the EPL, v1.0
The remainder of the presentation is licensed under Creative Commons Att. Nc Nd 2.5 li-
cense

Copyright © 2009 IBM Corp. & Red Hat, Inc.   All rights reserved.

Flow of the build

build.xml Script Generator com.acme.main.feature com.acme.ui

generate

Discover all the plugins and 
analyze their dependencies.

read feature.xml

read build.properties

assemble scripts

main target

invoke build .xml (gather.bin.parts)

read build.properties

generate

package scripts
generate

acme.ui build.xml

acme.feature build.xml

generategenerate

invoke build

invoke build.xml

invoke build.xml (gather.bin.parts)

process

assemble

generate
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Digging Deeper
● Explore the generated feature & plugin build.xml

● all.plugins, build.jars
● @dot, gather.bin.parts

● Import org.eclipse.pde.build into workspace
● File > Import > Plug-in Development > Plug-ins and

Fragments > org.eclipse.pde.build
● Look in scripts/build.xml: main
● Look in assemble*.xml and package*.xml
● Look in allElements.xml

● PDE Build Templates
● Look in templates/headless-build/customTargets.xml
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● XWT.Builder/build.properties
● RunPackager
● allowBinaryCycles
● flattenDependencies, parallelCompilation

● New in Eclipse 3.5M6!
● No longer need to worry about the order of 

subfeatures in a given feature.xml
● outputUpdateJars, generateJnlp
● forceContextQualifier = v20090323-0800
● generateFeatureVersionSuffix = hash of contents
● PluginPath
● BREEs, bootclasspaths, javacSource, javacTarget

Digging Deeper (cont'd)
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What else can PDE Build do?

● Download zip to use as a target

● Fetch map files and sources

● Hook in custom steps

● Generate source bundles/features

● Build products
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Exercise Review

● Review structure of PDE Build process
● Review contents of build.properties, what 

they do, etc.
● Review important locations
● Locations and how they fit with Athena
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Common Build Background
● Basebuilder and Releng Projects

● Common Build History

● Build Workshops

● Dash Athena Project
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Basebuilder and Releng Projects

● Basebuilder
● Subset of the Eclipse SDK (CVS, JDT, PDE) required 

to run PDE Build
● Includes org.eclipse.build.tools and custom ant tasks

● Releng Project
● Uses org.eclipse.releng.basebuilder
● Defines build information

● Project metadata (name, version)
● Source locations & branches/tags (map file(s))
● Optional extra packaging steps
● Defines 3rd-party requirements

● eg., Linux Tools requires CDT
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Common Build History
● Started with one build, OCL, Nov 2005

● By July 2006, there were 10 divergent builds
● 3rd party jars
● multiple upstream dependencies (eg., Eclipse, EMF,

UML2, OCL)
● JDKTM 1.4 & 5.0

● Now, with Xtext, there are more than 20!
● Some with as many as 10 upstream required builds

● Dash Athena Builder under development
● 2 projects so far (Linux Tools, GEF)
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Build Workshops
● Sept 2006 http://wiki.eclipse.org/Build Workshop 1: Build Hard

● Lots of release engineers from Eclipse projects
● More talk than walk

● June 2008 http://wiki.eclipse.org/Build Workshop 2: Build Harder
● Nick, Bjorn, Denis, et al
● Athena project started with first 3 committers
● GEF build is ported to run headless on build.eclipse.org

http://wiki.eclipse.org/Build_Workshop_1:_Build_Hard
http://wiki.eclipse.org/Build_Workshop_2:_Build_Harder
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Build Workshops (cont'd)
● Oct 2008 http://wiki.eclipse.org/Build Workshop 3: Build Hard With A Purpose

● Nick, Andrew O, Andrew N, Kim, Pascal, et al
● Athena grows to 6 committers
● Releng project greatly simplified

● Feb 2008 http://wiki.eclipse.org/Build Workshop 4: Code's Free So Build Hard
● Nick, Andrew O, Bjorn
● Support for building in Eclipse on Linux, Mac and Windows 
● Support for building, testing, and jar signing via Hudson

● Ongoing
● http://wiki.eclipse.org/Build_Workshop_Report
● http://wiki.eclipse.org/Category:Common_Builder
● http://www.eclipse.org/projects/project-plan.php?planurl=

http://www.eclipse.org/dash/athena/project-info/plan.xml&component=Athena

http://wiki.eclipse.org/Build_Workshop_3:_Build_Hard_With_A_Purpose
http://wiki.eclipse.org/Build_Workshop_4:_Code's_Free_So_Build_Hard
http://wiki.eclipse.org/Build_Workshop_Report
http://wiki.eclipse.org/Category:Common_Builder
http://www.eclipse.org/projects/project-plan.php?planurl=http://www.eclipse.org/dash/athena/project-info/plan.xml&component=Athena
http://www.eclipse.org/projects/project-plan.php?planurl=http://www.eclipse.org/dash/athena/project-info/plan.xml&component=Athena
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Dash Athena Project

● What it is
● A work in progress!
● A wrapper for PDE Build using org.eclipse.releng.basebuilder
● Ant tasks backed by some shell/exec calls (less over time)

● What it does
● Standardizes paths and variables
● Simplifies default offering, while allowing for customizations
● Uses Ant Contrib, Ant4Eclipse, and PDE SVN Plugin

● Where it runs
● In Eclipse (Windows, Mac, Linux 32/64)
● In Hudson & via commandline (Linux 32/64)
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Exercise:  Setup
(Network-based config; skip if projects already in workspace)

1. Download Team Project Set File (PSF):
http://dev.eclipse.org/viewcvs/index.cgi/org.eclipse.dash/athena/

org.eclipse.dash.commonbuilder/org.eclipse.dash.common.releng.tutorial/
psf/gef.psf?revision=1.1.2.1&root=Technology_Project

2. Import PSF using File > Import > Team > Team Project Set

3. You should now have these projects:
● org.eclipse.releng.basebuilder
● org.eclipse.dash.common.releng
● org.eclipse.gef.releng

4. Download ant-contrib-1.0b2 (not 1.0b3!): 
http://downloads.sourceforge.net/ant-contrib/ant-contrib-1.0b2-bin.zip

5. Unpack it, and put the renamed jar here:
● org.eclipse.dash.common.releng/lib/ant-contrib.jar

http://dev.eclipse.org/viewcvs/index.cgi/org.eclipse.dash/athena/org.eclipse.dash.commonbuilder/org.eclipse.dash.common.releng.tutorial/psf/gef.psf?revision=1.1.2.1&root=Technology_Project
http://dev.eclipse.org/viewcvs/index.cgi/org.eclipse.dash/athena/org.eclipse.dash.commonbuilder/org.eclipse.dash.common.releng.tutorial/psf/gef.psf?revision=1.1.2.1&root=Technology_Project
http://dev.eclipse.org/viewcvs/index.cgi/org.eclipse.dash/athena/org.eclipse.dash.commonbuilder/org.eclipse.dash.common.releng.tutorial/psf/gef.psf?revision=1.1.2.1&root=Technology_Project
http://downloads.sourceforge.net/ant-contrib/ant-contrib-1.0b2-bin.zip
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Building In Eclipse Using Athena

● Modify properties for your machine 
● Paths for Java, Ant, workspace dir, build dir

● Use local source checkout if you prefer
● Subsequent builds are faster, consume less bandwidth 

● Right-click releng project's build.xml 
● Run As > Ant Build

● Console log stored in releng project
● buildlog.latest.txt
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Exercise:  Configure & Run
● You should already have the example project 
org.eclipse.gef.releng checked out from 
Athena repository (see previous exercise)

● Open build.properties

● Right-click releng project's build.xml 
Run As > Ant Build

● Check console log output in 
buildlog.latest.txt
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Athena build.properties
● What & how to build:

projectid=tools.gef
zipPrefix=GEF
version=3.5.0
buildType=N
mainFeatureToBuildID=org.eclipse.gef.all
testFeatureToBuildID=org.eclipse.gef.test

JAVA_HOME=/path/to/java
JAVA14_HOME=/path/to/java
JAVADOC14_HOME=/path/to/java/bin

dependencyURLs=http://download.eclipse.org/\
eclipse/downloads/drops/\
S-3.5M5-200902021535/\
eclipse-SDK-3.5M5-linux-gtk.tar.gz

http://download.eclipse.org/
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Athena build.properties (cont'd)
● Where to get sources:

● If building from CVS or SVN, use map file(s)

● If building locally, use:
localSourceCheckoutDir=\
C:/workspace/org.eclipse.gef.tree

● To get local cache, import using gef-tree.psf 

● Or via command line:
● cd ~/workspace; cvs -d :pserver:

anonymous@dev.eclipse.org:\
/cvsroot/tools -q co -d org.eclipse.gef.tree \
org.eclipse.gef

file:///workspace/org.eclipse.gef.tree
http://dev.eclipse.org/viewcvs/index.cgi/org.eclipse.dash/athena/org.eclipse.dash.commonbuilder/org.eclipse.dash.commonbuilder.releng/psf/gef-tree.psf?root=Technology_Project&view=co
mailto:anonymous@dev.eclipse.org
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Troubleshooting
● Missing classpath or bootclasspath entries

● ant-contrib.jar (wrong version!)
● org.eclipse.pde.build.svn_*.jar
● dt.jar, rt.jar, classes.jar

● Map file problems
● Missing file? Missing entries in file? 
● Wrong feature or plugin id to path mapping?
● Invalid cvs/svn credentials?

● Testing problems
● Need Xvnc or Xvfb to run headless tests
● Missing org.eclipse.test or org.eclipse.ant.optional.junit?
● Note: tests do not currently run headless on Mac or Windows
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Troubleshooting (cont'd)
● Building from SVN sources

● Need an SVN client installed; PDE SVN does not include its own 
SVN implementation

● Platform-specific configuration tips

http://wiki.eclipse.org/Common_Build_Infrastructure/Virtual_Server_Setup/Fedora

http://wiki.eclipse.org/Common_Build_Infrastructure/Virtual_Server_Setup/MacOSX

http://wiki.eclipse.org/Common_Build_Infrastructure/Virtual_Server_Setup/WinXP

http://wiki.eclipse.org/Common_Build_Infrastructure/Virtual_Server_Setup/Fedora
http://wiki.eclipse.org/Common_Build_Infrastructure/Virtual_Server_Setup/MacOSX
http://wiki.eclipse.org/Common_Build_Infrastructure/Virtual_Server_Setup/WinXP
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Exercise: Verify Build
● Exercise: Install GEF SDK from Archived p2 

Repository (an update site with metadata)
● Help > Install New Software... > Add > Archive...
● Browse for GEF-Update-*.zip
● Uncheck 'Group items by category' checkbox
● Select GEF SDK feature
● Restart when prompted
● Verify GEF SDK is installed

Help > About > Installation Details

● Exercise: Install from SDK zip (Optional)
● Uninstall previously installed GEF SDK; restart when prompted
● Verify GEF is no longer installed. Close Eclipse
● Unpack GEF SDK zip into eclipse/dropins/gef/
● Restart Eclipse
● Verify GEF SDK is installed

Help > About > Installation Details
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Exercise: 
Install GEF SDK 

From Archived p2 Repo
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Exercise: Verify Build

● Exercise: Smoke Test (GEF Logic Example)
● Install GEF SDK as in one of previous exercises
● File > New > Example... > Logic
● Select generated project
● Run > Run As > Eclipse Application

● In second Eclipse instance
● New > Project... > General > Project
● New > Example... > GEF > Logic Diagram 

● Select Four-bit Adder Model
● Review generated diagram
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Exercise: Smoke Test 
(GEF Logic Example)
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Exercise: Smoke Test 
(GEF Logic Example) 

(cont'd)
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Exercise: Verify Build

● Exercise: Smoke Test (GEF Shapes) (Optional)
● Install GEF SDK as in one of previous exercises
● File > New > Example... > Shapes
● Select generated project
● Run > Run As > Eclipse Application

● In second Eclipse instance
● New > Project... > General > Project
● New > Example... > GEF > Shapes Diagram 
● Open palette on right side of editor; create a diagram
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Exercise: Smoke Test 
(GEF Shapes Example)
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Agenda
● Introduction

● PDE Build
● Exercise: Build a Feature
● Exercise: Generate a p2 Repository

● Common Build Background

● Dash Athena
● Exercise: Setup
● Exercise: Configure, Run, Troubleshoot
● Exercise: Verify Build

● Meet Hudson

● BYO Build Clinic
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Meet Hudson
● Continuous Integration 

(build when sources change)

● Change Tracking (CVS, SVN, ...)

● Automated Jar Signing

● Extensible Framework (Plug-ins)

● Parameterized Builds, Chained Builds

https://hudson.dev.java.net/ 

https://hudson.dev.java.net/
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Build Groups & 
Chained Builds
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GEF & Linux 
Tools Builds

History
Compiler Warnings
Test Results
Disk Usage
Build Status & Labels
RSS Feeds
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Source Change Tracking:
CVS & SVN
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Parameterized Builds
Build Duration Trending
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Build Artifacts
Build Signing
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Running Hudson 

● Download the latest hudson.war or .jar from 
https://hudson.dev.java.net/ 

● java -jar hudson.war

● (That's it!)

https://hudson.dev.java.net/
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Agenda
● Introduction

● PDE Build
● Exercise: Build a Feature
● Exercise: Generate a p2 Repository

● Common Build Background

● Dash Athena
● Exercise: Setup
● Exercise: Configure, Run, Troubleshoot
● Exercise: Verify Build

● Meet Hudson

● BYO Build Clinic
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BYO Build Clinic / Q&A

● Bring us your checked out sources, we'll try 
to get you running w/ an Athena build

● Any questions?

● Want more? For extra credit, see the next 
two slides. 
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Exercise: Linux Tools (Optional)
● Try building the Linux Tools project!

● Get org.eclipse.linuxtools.releng project 
● See psf/linuxtools.psf file in tutorial zip

● Source tree can be fetched from
● http://dev.eclipse.org/svnroot/technology/org.eclipse.linuxtools/

● Configure releng/build.properties to include 
required dependencies: JDK 6.0, Eclipse, 
EMF, GEF, CDT & BIRT.

● Run build.xml!

http://dev.eclipse.org/svnroot/technology/org.eclipse.linuxtools/
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Exercise: Build in Hudson (Optional)
● Try building with Hudson, either locally or on 

a virtual server. See 
http://wiki.eclipse.org/Common_Build_Infrastructure/Virtual_Server_Setup 

● Start Hudson. Open http:/localhost:8080

● Create a new job

● Launch a GEF or Linux Tools build using
● org.eclipse.dash.common.releng/tools/scripts/start.sh

● (Run script without options for examples and 
summary of commandline flags)

http://wiki.eclipse.org/Common_Build_Infrastructure/Virtual_Server_Setup
http://wiki.eclipse.org/Common_Build_Infrastructure/Virtual_Server_Setup
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